It all started with a trip around Saturn…

And then I met Lara Croft! But this story doesn’t have a happy ending…

I have a very modest PC which runs 24/7 in support of my website. The on board 800MHz graphics was fine for most things, but not particularly good for gaming.

For years I’ve been following a development called Space Engine. The program (for PC) has been in beta mode for at least five years. It’s a graphics hungry universe simulator which recreates the known (and unknown) universe on a scale of 1:1. It’s totally awesome. It ran reasonably well on my machine when set with the lowest graphics settings, and I loved it.

About a month ago, Space Engine launched its first paid (but still under development) version on Steam. It costs just under £20. To cut a shortish story even shorter, it didn’t run at all with my graphics card. This was kind of expected, although disappointing. I needed to upgrade the graphics card, so I bought the (recommended) Nvidea Geforce GTX 1060 for about £180.

Yay! It ran perfectly for all of… 10 minutes. As the graphics became more complex (ie when cruising near a super-massive black hole), the PC fans got faster and faster, then it shut down. That’s the thermal protection kicking in… but that’s not surprising that close to a black hole. To get an idea, check out this video: https://youtu.be/eYp-IEz_i6E?t=3530

In fact I found that it crashed the computer far too often, and I soon realised that I should make sure the graphics firmware was up to date. Sure enough, the supplied driver version was about six months old. The update and some lowering of the graphics card clock speeds reduced the number of crashes.

Now, what’s this all got to do with Lara Croft? Well, I’ll tell you. Nvidea were bundling Shadow of the Tomb Raider with the graphics card, so it occurred to me that they would only do this if they were confident that the card would run ok with it without getting too hot. As I wouldn’t normally play games like this (mainly due to my rubbish system!) I gleefully downloaded the massive 28GB game overnight, and gave it a try.

It seemed to run fine, (except Lara seems to look a bit like Princess Fiona from Skrek, but that’s not going to be the fault of my system).

I digress… So I ran the game for about 10 minutes, playing through the intro and in-game videos with ease, and then on to some actual game play. I then hear the fans in my PC winding up the revs faster and faster as the intensive jungle scenes are shown. “Ah!” me thinks, “This game is supposed to run fine with this graphics card, else they wouldn’t have offered it for freeeee!!”

It was the last thought I had before… BANG! Followed by electrical crackling noises, and my screens went dead. The strong and sweet smell of burnt insulation wafted around the room and all was quiet, except for my daughter calling from the room next door “Dad, what just happened?”

I fear that I should have heeded the warning signs when I was orbiting Saturn a couple of days ago…

So, the long and the short of it is that I hadn’t checked the power budget and it blew at least one resistor in the power supply.

The GTX 1060 requires 400W. My PC had a 500W PSU. It also had a motherboard with a 4 GHz CPU, three disc drives and multiple fans to supply. The picture above is the result.

So, an 850W PSU is on the way, costing another £55.

My appointment with Lara is on hold… so meanwhile here is a video of Space Engine on Youtube for you to enjoy.

Leave a Reply

Your email address will not be published. Required fields are marked *